Main Page

From RapidSVN
Jump to: navigation, search

Milestone 64x64.png Download the latest released version: 0.12.1

Nightly 64x64.png Download a development version

Contents


About this site

This site is a Wiki. That means that once you register for an account, you can log in and update any page on the site yourself. Please edit a page only if you can improve it.

Mission of this site

We want to provide help and support for the users of RapidSVN. This will include Online Help, Tutorials and HOWTOs.

The main communication about the ongoing development takes place in the different mailing lists of RapidSVN. This includes support for users or administrators as well as discussions or polls about new features.

Visit http://rapidsvn.tigris.org/ds/viewForums.do to check out the different mailing lists.

About RapidSVN

RapidSVN is a cross-platform GUI front-end for the Subversion revision system written in C++ using the wxWidgets framework. This project also includes a Subversion client C++ API.

RapidSVN is licensed under the GNU GENERAL PUBLIC LICENSE v3.

Mission of RapidSVN

We want to build a best of breed visual client that utilizes the best features of clients from other revision control architectures. While being easy enough for users new to Subversion to work with it must also be powerful enough to make experienced users even more productive.

Features

  • Simple - provides an easy to use interface for Subversion features
  • Efficient - simple for beginners but flexible enough to increase productivity for experienced Subversion users
  • Portable - runs on any platform on which Subversion and wxWidgets can run: Linux, Windows, Mac OS/X, Solaris, etc.
  • Fast - entirely written in C++

Dependencies

RapidSVN depends on a couple of frameworks. So if you want to compile RapidSVN you have to download, configure and compile these frameworks first (unless you have access to a precompiled binary package with development files like headers and libraries included).

  • Subversion 1.2.3 or higher download (we work with Subversion 1.7.1)
  • wxWidgets 2.6.2 or higher download (we work with wxWidgets 2.8)
Personal tools